
A New Style for the TrainPlayer User Interface

Note: This quick start guide is intended as a memory aid and is not intended to be a detailed tutorial.

The first thing an experienced user will notice after upgrading to Version 8.2 of either TrainPlayer, or TrackLayer, is 
a striking new set of Scaleable Vector Graphic (SVG) icons on the toolbars. These replace the original low 
resolution bitmap files which have been a feature of TrainPlayer since the release of version 1 in 2005.

To avoid confusing new users with a display of more than 60 unfamiliar icons, holders of a TrainPlayer Operator 
license will initially see a single toolbar, the Main toolbar, with eight buttons labeled to explain their purpose.

TrackLayer Builder license holders will see two toolbars, the same Main toolbar, plus the Build toolbar which is 
needed for track laying and scenery selection, and for accessing another toolbar for scenery production work.

Both of these permanent toolbars are initially docked at the top of the display.

For experienced users, all the toolbars are customizable regarding content, position, button size and label status.

The first thing a New User needs to know

To load a layout from your Layout Chooser, select “Open
Layout” on the Main Toolbar, then select a layout from the
Chooser and click OK. You can also access “Open Layout” from
the File Menu or select a file from the “Most Recently Used”
files list at the bottom of the File Menu.

Click on any engine in the main display to select it and then
use the Train Control Bar to operate your train. Click the Auto
Follow button on the Main Toolbar to scroll the background
and maintain the focus on your moving train.

Tap the Space bar to throw the switch immediately ahead of your 
moving train to change the route, or use your mouse to click on the
frog position of any turnout on the layout to change the switch 
direction setting.
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Tabbed Layout Selection

TrainPlayer now uses a tabbed approach for swapping between multiple layouts that are open at the same time.

Each layout that you open now has its own tab at the top of the screen and there is no longer any need to go to 
the Windows menu to change to a different open layout. If there are too many layouts open to display all their 
names on the tabs you can use the \/ drop down menu to make your selection.

The Windows Menus

The Windows menus follow a standard arrangement which will be familiar to existing users and newcomers alike. 
File Tools for opening, closing, creating, importing, printing and saving files, and setting layout preferences.
Edit Contains the standard Windows editing tools such as Cut, Copy, Paste, Delete, Undo and Redo.
View Tools to change the status of the display such as selecting full screen mode and displaying car ID labels.
Tools Tools for accessing Choosers and dialogs, checking viability of tracks, and resizing and rescaling a layout.
Train Tools for controlling and building trains – most of these are also available on context menus. 
Window Tools for generating additional display windows and for tiling or cascading any open windows.
Help Access to the comprehensive Help file, plus tools for checking, updating and registering TrainPlayer.
Experienced users may notice that some tools have now migrated from the View Menu to the Tools Menu.

Dynamic Positioning of Toolbars

“Dynamic Positioning” is the name we have given to the new default behavior for Toolbars. There are two 
permanent toolbars “Main” and “Build” for a user with a Tracklayer Builder license, or a single permanent “Main” 
toolbar for a user with a TrainPlayer Operator license. On program start up the Main and Build toolbars are always 
docked in a single row at the top of the application window. Either or both of these toolbars can be relocated to a 
new position such as docked to the left or right side of the display but, with Dynamic Positioning active they will 
always return to these default positions the next time TrainPlayer is restarted.

There are six additional subtoolbars which can be selected from the Main and Build toolbars. Only one subtoolbar 
will be displayed at any one time, it will default to opening superimposed over the left end of the Train Window. 
Opening a new subtoolbar will automatically close any other open subtoolbar so that it can occupy roughly the 
same position as its predecessor did in the work space. This ensures that only tools relevant to the current task in 
hand are displayed at any one time. This should shorten the learning curve for novice users by eliminating the 
need to search through 60 or more unfamiliar and unlabeled tool buttons to find the required tool, as well as 
releasing valuable display space for layout design and operation. If you choose to move a subtoolbar to a new 
position, the co-ordinates will be remembered and reused whenever that subtoolbar is reopened during the 
current operating session. The default position will be restored automatically when TrainPlayer is restarted.

Experienced TrainPlayer users should also benefit from the Dynamic Positioning of toolbars but for any user who 
still prefers to display all his toolbars simultaneously we have included a feature on the Preferences > Style page to
switch off the Dynamic Positioning. This returns all toolbars to an equal status with no hierarchy and no automatic 
closing of toolbars. Each time you restart TrainPlayer your toolbars will always return to the same position that you
had last placed them. With either system you have full control over the customization of button size, appearance 
and content of the toolbars.
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The Main Toolbar

Open Layout Launches the Layout Chooser and enables you to select a published or saved layout for loading.
Pause Pauses all moving trains whether they are Scripted or not. Displays an option to resume.
Auto Follow Keeps the moving train within the display space by continually scrolling the background.
Paint Shop Accesses the Paint Shop dialog for customizing individual cars. See Help File > Paint Shop.

The remaining four buttons each include a small downward facing triangle symbol which signifies that the button 
opens a further subtoolbar with additional tools for a specific task. To close a subtoolbar after use, click the same 
button again, or click the Windows close X symbol on the subtoolbar. The subtoolbar will also close if you select a 
different subtoolbar – this permits the same display space to be reused by the new subtoolbar.

Opens or closes the View Options subtoolbar to facilitate the selection or deselection of the 
different layers which make up the TrainPlayer display image. In the example below the center track 
line, stations and track grid are not displayed but all the other “selected” features will be visible. 

Opens the Script Tools subtoolbar. Please see the Scripting Page of the TrainPlayer website for 
information about Scripting. http://www.trainplayer.com/Features/Scripting6/index.htm
or refer to the Scripting section of the Help File.

Rewind All Rewinds all completed or partially run scripts and returns the trains to their start positions.
Stop All Immediately stops all running scripts. Also stops all moving trains whether scripted or not.
Start All Starts the scripts running after loading a scripted layout.
Edit Script Opens the Train Script editor dialog for writing or editing a script for the selected train.
Script Central Opens the main Control Center for Script Management.
Command Box Opens the Command Prompt dialog for entering Scripting Language instructions directly.
Schedule Window Displays the Schedule Window for reviewing debug information when testing scripts.
Record Commences automatic recording of all train commands to permit future replay.
Set Rewind Point Sets a new Rewind Point, or Script start position, for returning to using Rewind All.

Opens the Ops Tools subtoolbar. Advanced Ops was introduced with TrainPlayer 7.0 and upgraded 
with version 7.2 in 2020. For links to the latest documentation about designing and running 
Advanced Ops layouts please go to http://www.trainplayer.com/Features/Version72/index.htm

Ops Central Opens the Ops Central dialog for reading, setting and editing all Ops related data.
Active Engine Zooms to the engine used for the current switchlist (AO layouts only).
Routefinder Selects and deselects the Routefinder tool.
View Waybill Displays Waybill Information for the selected car. (intended for AO layouts).
Map View Displays an overall miniature Map View of the whole layout.
Schedule Window Displays the Schedule Window for reviewing debug information.

The Train button opens the Train Tools subtoolbar. 
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Train Tools continued:
Shift Forward Move the selected car forward one place towards the lead car.
Shift Backward Move the selected car backward one place towards the last car.
Flip Car Flip the selected car image to face in the opposite direction.
Flip Train Flip the complete train so that it faces in the opposite direction.
Train Properties Open the Train Properties dialog to apply a customized train name.
Add Car Add a new car to the train from a list of car types or select a car from the Car Chooser.

The Build Toolbar

Run Selects Run mode for train operation, deselects any active Build Tools and closes open subtoolbars.
Edit Track Allows cursor selection of individual tracks or shift cursor selection of multiple tracks for editing.
Straight Activates the Straight Track drawing tool for direct drawing or connecting up Guide Circles.
Circle Activates the tool for drawing Guide Circles for accurate laying of curved tracks.
Turntable Activates the tool for drawing Turntables.
Edit Scn For selecting and adjusting Scenery objects within the active layer (Foreground or Background).
Scn Tools Opens an additional subtoolbar for designing, drawing and editing new Scenery objects.

The Scn Tools button opens up another set of tools which enable you to draw and manipulate scenery objects on 
your track plan – you can find a Scenery tutorial here, or check the Help file.
 http://www.trainplayer.com/Features/Scenery/clappison/Clappison.html

Foregr Layer Foreground objects are drawn above the ties and roadbed, but below the rails and trackline.
Backgr Layer Background objects are drawn below trackline, rails, ties and roadbed.
Line/Polygon For drawing lines and polygons in the active layer, uses the style setting in the Scn Styles dialog.
Rectangle For drawing rectangles in the active layer, uses the style setting in the Scn Styles dialog.
Ellipse For drawing circles and ellipses in the active layer, uses the style setting in the Scn Styles dialog.
Text For drawing rectangular text boxes in either layer using color and style from Scn Styles.
Painter For recoloring scenery. Shift-click to pick up a color, click another object to add the new color.
Arrange Opens an additional subtoolbar for grouping and layering existing scenery objects. *
Scenery Grid Displays a grid of dots to use as a guide when drawing shapes with the polyline tool.
Scn Chooser Accesses the Scenery Chooser, a library of existing images in the TrainPlayer collections.
Scn Styles For setting colors and properties for lines, backgrounds and text for use by the drawing tools.

Note: The Background Fill color is also the color currently being used by the Painter Tool.

* The Arrange tools are for organizing the grouping and position of Scenery objects by providing 
control over the way one object overlays another. Several scenery objects can be grouped to form a 
single object and composite objects can be ungrouped into their component parts.

Bring Forward Click to bring the highlighted object(s) forward one place in the image stack.
Send Backward Click to send the highlighted object(s) backward one place in the image stack.
Bring to Front Click to bring the highlighted object(s) to the front of the image stack.
Send to Back Click to send the highlighted object(s) to the back of the image stack.
Group Click to group multiple highlighted objects into a single composite image.
Ungroup Click to ungroup composite images into their component source images.
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Overriding Dynamic Positioning

Dynamic Positioning ensures that the two permanent toolbars – Main and Build – will only open one additional 
subtoolbar at any one time but you can still access additional subtoolbars at the same time if you need to.

To do this just right click on any toolbar and apply a check mark against the additional subtoolbar you need to 
open, repeat this to open more subtoolbars. To close any unwanted subtoolbars just reverse the process or click 
the Close button. 

If you have opened several additional toolbars in this way you can close down all the open subtoolbars 
simultaneously by Clicking on the “Run” tool.  This will leave only the Main and Build toolbars active 
Note: You can only do this if you have not canceled Dynamic Positioning setting on the Preferences Style tab.

Adding and Removing Toolbar Buttons

To remove a toolbar button.
1. Click on the down arrow at the bottom right of the Toolbar window.
    Note: On floating subtoolbars this down arrow is located top right adjacent to the Windows X close button.
2. Hover over “Add or Remove Buttons” and navigate to the toolbar and the name of the button to be removed.
3. Uncheck the button to immediately remove it from the toolbar.

To add a new toolbar button.
1. Click on the down arrow at the bottom right of the Toolbar window.
2. Hover over “Add or Remove Buttons” and navigate to the name of the button to be added.
3. Click on the name of the button required to add it to the toolbar.

Buttons that can be added using this method are restricted to the defaults listed on the appropriate menus but 
you still have full control over toolbar customization if you use the alternative method detailed below.

To reset any toolbar to its default state and position.
1. Click on the down arrow at the bottom right of the Toolbar window.
2. Hover over “Add or Remove Buttons”, then navigate to and Click the appropriate Reset Toolbar option.
3. To reset All Toolbars, right click on any toolbar, select Customize, select the Toolbars tab and Click Reset All.
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Customizing Toolbars and Menus

For total control over customization of toolbars and menus, start by right clicking on any toolbar and selecting 
“Customize...” to open the Customize dialog. Note: This dialog is also available from the Tools Menu.
While the Customize dialog is open your Toolbars and Menus will no longer function but you are free to move or 
copy Toolbar Buttons and Menu Commands to produce a personalized interface to suit your own way of working. 
You can rearrange buttons within the toolbars and between the toolbars and menus. It therefore makes sense to 
ensure that every required toolbar is open before you launch the Customize dialog.

A Worked Example to add a copy of the Full Screen command to the View Options Subtoolbar
With the View Toolbar open right click on any toolbar and select Customize to open the Customize dialog.

Click on the View Menu to open it, Click to highlight the Full Screen command, holding down the Ctrl key drag the
Full Screen command to the required position on the View Options toolbar and release the mouse button to place
a copy of this command on the View Options toolbar. 
Warning: If you do not hold down the Ctrl key you will move this command from the menu instead of copying it.
When you close the Customize dialog your new tool will be available to use from the View Options subtoolbar.

Building your own Menus
Once the Customize dialog is open you have access to every TrainPlayer tool.
Select a menu in the categories section, select a Command from the 
Commands section, and drag the command onto any toolbar or menu.
You can even build a completely new personalized Menu using the New Menu
command and populate this with commands from any of the other menus 
listed in the Customize dialog.
Initially this will have the name “New Menu” but you can rename this to 
something more appropriate by right clicking the name and selecting the 
Button Appearance option.
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The Quick Access Toolbar (QAT)

The Quick Access Toolbar (or QAT) is new for TrainPlayer 8.2. This toolbar sits permanently at the top left corner of
the application window and is intended for tools to which you might require permanent access because the same 
tool is often needed for totally different types of tasks. By default the QAT is equipped with buttons for Cut, Copy, 
Paste, Undo, Redo, Save, Save All and Refresh. As with all things in TrainPlayer the QAT is fully customizable. In this
example we have added both the Command Prompt and Revert to Saved buttons to the toolbar.

Customizing the QAT is a straightforward procedure but you can’t move buttons around on this particular toolbar. 
The order is dictated by the defaults followed by the order in which you choose to add any additional buttons. 

To remove a toolbar button from the QAT, right click on the toolbar and toggle off the toolbar icon.

To add a new button to the QAT, right click on the toolbar, hover over the More option at the bottom of the menu,
navigate to the required new Command, then Click to select it and add the new icon to the QAT toolbar.

Modifying the Toolbar Preferences

Experienced users can adjust the Toolbar preferences on the Style tab of the 
Preferences dialog should they wish to do so. Preferences is available from the 
File menu. There are three button sizes – Small, Medium and Large. 

To assist inexperienced users the default settings are for Medium sized icons with 
optional Text labels and with Dynamic Positioning switched on.

If you uncheck the Dynamic Positioning your toolbars will all remain on display 
until you choose to close them individually. To display all the available toolbuttons
at once you will probably need to use Small size buttons without Labels.

R.F. for TrainPlayer.   September 2022
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